Upgrading to NuoDB 3.0 Patches

{question}

I have installed NuoDB 3.0 and am trying to upgrade to the latest patch release. I keep seeing this message:  nuoagent: unrecognized service. What am I doing wrong? 

{question}

{answer}

If you perform an upgrade using "rpm -U" when starting the nuodb service (e.g.  "service nuoagent start"), you will see this message "nuoagent: unrecognized service". 
 
Avoid this message by confirming that you are installing v3.0-9 or higher and re-run the upgrade with the additional argument "--replacepkgs" (e.g. rpm -U --replacepkgs nuodb-3.0.0.9.x86_64.rpm). 
 
Alternatively, you can upgrade to the latest patch level by performing a new install instead of an upgrade.
 

If you need help with this or if you have questions, feel free to reach out to us.

{answer}

Have more questions? Submit a request

Comments