NuoDB for Windows can fail to start after installation or update

 

 

{problem}

On some Windows installations, NuoDB Support has received reports of the inability to start Transaction Manager (TE) and Storage Manager (SM) processes after installing or upgrading to NuoDB versions created during or after March 2016.  This includes NuoDB versions 2.4.1 and 2.5.2 and later.  

A typical example of the error message is shown below:

Application Name: nuodb.exe
Application Version: 2.5.2.1
Fault Module Name: i-ms-win-crt-runtime-l1-1-0.dll

{problem}

{solution}

Beginning with releases in this time period, NuoDB for Windows is built using a newer compiler which requires that the latest Universal 'C' Run-time (CRT) libraries be present on the target operating system.  Some older operating systems may need to have these libraries installed or be updated to include these libraries.  

Please make sure that your Operating System is up to date and refer to Microsoft(tm) Knowledge base article KB-2999226 for specific information about installation of the required dependency.  Please note that we have seen cases where additional updates are needed prior to installing this update. 

{solution}

Have more questions? Submit a request

Comments